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CalendarAnything LWC is a Salesforce.com application that allows Users to create calendar views from any 
Standard or Custom objects that are a date or date/time field. CalendarAnything LWC can be downloaded from the  
AppExchange at: 

HTTP://APPEXCHANGE.SALESFORCE.COM/

This advanced admin guide is recommended for system administrators who already have at least a basic 
understanding of CalendarAnything LWC functionality. 

Salesforce.com supported editions: 
Enterprise Edition, Unlimited Edition, Force.com Platform Edition, Developer Edition

Overview

Technical Specifications

Salesforce.com users without the above versions are unable to use the app, even if CalendarAnything 
LWC licenses are assigned to the User. 

Implementation of the features described in this admin guide will require system administrator access 
to the organization.

http://appexchange.salesforce.com/
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All CalendarAnything LWC clients are required to make the permission changes below. These changes will need to 
be made for all profiles or permissions sets that apply to Users using CalendarAnything LWC.

1.	1. Navigate to Setup >> Security >> Sharing Settings.

2.	2. Make sure that Organization Wide Default access in Internal and External columns is set to Private for 
all objects with “CA__” prefix. 

3.	3. From Setup, click Users | Profiles.  

4.	4. Select a profile.

User Permissions Needed 

Enhanced Profile User Interface Standard Profile User Interface

In Apps, click on Object Settings.

Select any of the CalendarAnything LWC custom 
objects, these objects have the CA_ prefix. 

Check the Read column to see if all fields are 
checked. If all fields are checked select the next 
CA_ custom object.  

If some fields are unchecked, click the Edit 
button and check all fields under the Read 
column.

Save changes. 

Make sure the profile has Create permission on 
CA_UserSettings.

Repeat for the next CA_ custom object.  

Repeat until all fields on all CA_ custom objects 
are visible for that profile. 

 
In Custom Object Permissions block, make 
sure the profile has Create permission on CA_
UserSettings. 

Scroll to the Field Level Security section. 
 
Locate the CalendarAnything custom objects, 
these objects will have the CA_ prefix.

Click View next to each CA_ custom object to 
show the field security settings. 

Check the Read Access column to see if all 
fields are checked. If all fields are checked, click 
Back to Profile button.  

If some fields are unchecked, click the Edit 
button and check all fields under the Read 
Access column.  

Save changes. 
 
Return to profile details and repeat for the next 
CA_ custom object. 

Repeat until all fields on all CA_ custom objects 
are visible for that profile.
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Enable profile access to CalendarAnything LWC custom Apex classes and Visualforce pages

Next, enable Apex Class Access for all CalendarAnything LWC components (those with the SLCALWC.CA_ 
prefix). Also enable Visualforce Page Access for all CalendarAnything LWC components (also beginning with the 
SLCALWC.CA_ prefix).
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Please see the explanations of CA_ custom object functions to determine what other permissions User profiles 
might require. 

CA_ object functions to help in determining sharing settings.

Object Name Function User Profile Permissions Needed
CA_Calendar Main object used for storing Standard Calendars. Read, Create (if creating calendars), Edit, Delete 

(if  deleting calendars), View All.

CA_HoverFields Stores fields that display on the “hover dialog” Read, Create, Edit, Delete, View All.

CA_CreatingField Stores fields used on the “Quick Create” popup 
when creating events from the CalendarAnything 
page

Read, Create, Edit, Delete, View All.

CA_CalendarToken Stores calendar token Read, Create, Edit, Delete, View All.

CA_Filters Stores information about calendar filters Read, Create, Edit, Delete, View All.

CA_Groups Stores information about calendar groups Read, Create (if creating Calendar Groups), 
Edit, Delete, View All.

CA_UserSettings Stores user settings such as a list of visible 
calendars

Read, Create, Edit, Delete, View All.

CA_WebCalendar Stores list of Web Calendars. Will not be used by 
clients

Read, Create, Edit, Delete, View All.

Another way to ensure the necessary access to CalendarAnything LWC is given, is to use a Permission Set (now 
included in CalendarAnything LWC). 

Add a Permission Set
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When added to the user record, this Permission Set allows creating and editing of calendars, subject to other 
object permissions and sharing rules. 

CalendarAnything LWC Default Permission Set 
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Publishing CalendarAnything LWC on Force.com
Create a Lightning App
The CalendarAnything LWC can be displayed on a force.com site. 

To create a lighting app, navigate to Salesforce and click on the gear icon in the top right corner. Then choose 
Developer Console from the dropdown.

In Developer Console, Click File > New > Lightning Application.

A System Administrator should help with the set up.
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Name the application (Ex:calendarLWC) and make sure to check the ‘Lighting Out Dependency App’ checkbox.

That creates something that looks like: 

Remove everything and copy/paste the following:

<aura:application access=”GLOBAL” extends=”ltng:outApp” implements=”ltng:allowGuestAccess” />

It should look like this:

Save by going to File > Save.
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Create a VisualForce Page That Our Site Will Load
To create a VisualForce Page, navigate to Setup > VisualForce Pages > click New.
Fill in the fields in the Page Information section. Make sure to check the Available for Lightning Experience, 
Lightning Communities, and the mobile app checkbox.

On the next page is a code sample for the site. In this example, we include Calendar IDs, but replace them with the IDs 
of the calendars you need to display and enable on your site when you copy and paste. Copy from <apex:page> to  
</apex:page>.
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<apex:page >
<apex:slds />
<apex:includeLightning />
<div id=”calLightning” class=”wrapper”></div>
<script>
    var calendarApi = null;
    // Create custom app and expose it to VisualForce
    $Lightning.use(‘c:calendarMobileApp’, function () {
        // add some settings
        let userAdditionalSettings = {
            displayTimeZone: true,
            dayModeArea: ‘0_1’,
            readonly: {
                move: false
            }
        };
        $Lightning.createComponent(
            ‘SLCALE:CALWC’,
            {
               calendar: “a024T00000257LDQAY, a024T00000257LFQAY”, 
//These are just example IDs and should be replaced with your CalendarIDs
               enabled: “a024T00000257LDQAY, a024T00000257LFQAY”, 
//These are just example IDs, you should be replaced with your CalendarIDs
            view: ‘Agenda’, // The default start view mode, in this example we are defaulting 
to Agenda.
                showModeSelector: true,
                userAdditionalSettings: JSON.stringify(userAdditionalSettings),
                useCAForm: true,
                useCADetail: true,
                showIcoCreate: false,
                showIcoCalendars: false,
                height: ‘600px’,
                readonly: {
                    move: false
                },
                // executes after calendar is fully loaded
                fReady: function (oApi) {
calendarApi = oApi; // for calendar API method (set dynamic filters, create custom buttons, 
etc);
                }
            },
            ‘calLightning’, // id of div you want to put new Lightning element
            (cmp) => {
                // callback for create element (NB calendar load event is not equal to this 
event).
                // if you want to execute something after calendar is loaded use fReady
                console.info(‘created’);
            }
        );
    });
</script>
</apex:page>
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Create a Force.com Site Page
To make your CalendarAnything LWC public, you must create a force.com site page. This can be an existing page 
or a new one. To set up your Force.com site, refer to SALESFORCE’S SETTING UP SALESFORCE SITES.

Once on the site set up, replace the Active Site Home page with the VisualForce page we just created.

Save and your site is ready to be published. 

If your site is brand new, then you will need to configure Sharing Rules as well (see next page).

https://help.salesforce.com/articleView?id=sites_setup_overview.htm&type=5
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Create Sharing Rules for Guest Site User on Your Force.com Site
First, go to the gear icon on the top left of your page and then click on Setup. Once there, click on Sharing 
Settings.

In Organization Wide Defaults, click on the Edit button.

Then, turn the Secure Guest User Record Access on.

Scroll all the way to the bottom to find this option.

In order to support the visibility of the calendar and the data exposed by CalendarAnything LWC, your system admin 
must create sharing rules for all objects exposed on a Force.com site.

For example, to publish a force.com site with an event calendar see the next section, Create a Sharing Rule For 
CA_Calendar Object.
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Create a Sharing Rule For CA_Calendar Object
Fill in the Sharing Rule label. The criteria defines what will be shared with your site user and depends on your use 
case. In this example, we will create a rule that gives the Guest Site user access to all calendars. Please make sure 
you are sharing with the right Guest Site user.

Once shared, the Guest Site user can access the calendars but not the records displayed on the calendar. 
You will have to replicate the process for each object that feeds into the calendar. 
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Salesforce is removing the View All, Modify All, Edit, and Delete object permissions on all objects for guest users in 
new and existing orgs. These permissions are removed for custom objects and standard objects. Guest users can 
only have Read and Create object permissions. See SF SPRING 2021 RELEASE NOTES for more. 

How does this change affect calendars published on Force.com sites?

Guest Site Users will receive an error message and will not be able to view the calendars. If the View All, Modify All, 
Edit, and Delete object permissions are part of a permission set or permission group and assigned to a guest user, 
then the guest user is removed from the permissions set or permission set group. Guest users also lose access to 
other permissions that are included in those permission sets and permission set groups.

CalendarAnything LWC Default Permission Set includes Edit and Delete permissions for CalendarAnything LWC 
custom objects. 

This is what your organization’s Salesforce admin will need to do before the Spring’21 Release is applied 
to your organization to avoid service interruption for Force.com calendars.

	ο Clone CalendarAnything LWC Default Permission Set

	ο Open newly created permission set

	ο Go to Object Settings

	ο Update object permissions for CalendarAnything LWC custom objects to Read access

	ο After the new permission set is ready, update Permission Set Assignment for all Site Guest Users

In Setup, go to Sites > click on Site Label > Public Access Settings > View Users > click on user’s Full Name 
> Edit Assignments (Permission Set Assignments).

Create and Assign Custom Calendar Anything LWC 
Permission Set for a Guest User

https://help.salesforce.com/articleView?id=release-notes.rn_experiences_crud_perms_removed.htm&type=5&release=230
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CalendarAnything LWC properties
CalendarAnything LWC properties are optional.

Default View Mode
Agenda is the default view. Admin can change the 
default view to one of other options we offer, such as 
Day, Day with grouping or Week. 

Calendars Available to Enable
Admin can list Calendar friendly names (comma 
separated) or Calendar IDs to limit the number of 
calendars available to users. 

Calendars to Enable at Startup
Admin can list Calendar friendly names (comma 
separated) or Calendar Ids that will be loaded by 
default every time the user opens the page. It will 
override any selection made by the user from the list 
of available calendars. If left blank, no calendars will 
be loaded when the user opens the application for the 
first time. To enable calendars, tap on the navigation 
icon and select calendars from the list. 

Calendars Available for New Records
Admin can limit the list of calendars available to users 
to create new records. Enter calendar ID or Name 
from ‘Name and Color’ of calendar setup. 

Height
Set component height in px. For mobile recommended 
height value is set to 500. 

Auto Hide Date-Picker property
When checked, will auto hide date picker calendar 
after user selected some date. 

Record Dynamic Filter Field property
Used to filter records when a component is placed on 
the record page. For example:

	ο Add component on Account page 

	ο Set Record Dynamic Filter Field = Id 

	ο Add Dynamic filter on Calendar Edit > ‘Filter 
Criteria’: Related To = DYN 
Then only calendar events related to the 
current Account will be displayed with the 
component. 

Display Mode Selector
If checked, will display View Mode selector. 

Display Create New Record Icon
If checked, will display + icon (Create New). 

Display Calendar Selector
If checked, will display Calendar Selector. 

Display Refresh Icon
If checked, will display Refresh icon. Clicking the 
Refresh icon will display the latest records for all 
selected calendars.
 
Display Today Icon
If checked, will display Today icon. 

Use CalendarAnything Create Form
If checked, will use a custom record create form 
based on Create and Edit Popup within calendar 
setup. Otherwise, will use standard new record layout 
for selected record type. 

Enabled Calendars Only on Create
If checked, will only display the currently selected list of 
calendars to choose from when creating new records. 

Additional User Settings
Admin can specify default user settings in JSON format. 
For example: {“swimlaneEnableListViews”:false} 

Max Reference Options
Admin can define the number of related lookup 
objects to load on start. For optimal performance, we 
recommended to set Max Reference Options to 10 
or less. 

Static Caching Time (minutes)
Cache time limit for object’s metadata and user’s 
permissions. 

Session Caching Time (minutes)
Cache time limit for calendar’s information.
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Purchasing CalendarAnything LWC Licenses 
CalendarAnything LWC costs can be found on our APPEXCHANGE LISTING. 
Initial license purchases are at the annual rate for a one-year subscription which entitles you to all upgrades of the  
application released during the year. Any additional licenses prior to the subscription renewal date will be calculated 
on  a prorated basis.

You are not required to purchase CalendarAnything Licenses for all Salesforce users in your organization--only for  
users needing Read, Write or Edit access to CalendarAnything.

For larger companies, Silverline CRM offers volume discounts and a site license option. We also offer a nonprofit  
discount. Please contact us for details. 

You are able to purchase licenses directly from the CalendarAnything package installed in your organization via  
Stripe Checkout.  

To purchase licenses via Stripe Checkout directly from the installed package, navigate to Your Name>> Setup>>  
Installed Packages. Click the Configure link and a Stripe Checkout window will appear. Follow the on-screen  
instructions to purchase your licenses. Once the purchase is complete, the CalendarAnything licenses will be active  
in your organization. 

If you are unable to purchase licenses using this method, contact us at: calendaranything@silverlinecrm.com 

https://appexchange.salesforce.com/appxListingDetail?listingId=a0N3u00000MSzSIEA1
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Support
VISIT OUR CALENDARANYTHING LWC SUPPORT SITE

Since 2009, Silverline has helped clients deploy, manage, and enable continuous value with 
Salesforce’s portfolio of products. Silverline also develops powerful solutions deployed on 
the Salesforce Platform, best practice industry accelerators, and robust third-party apps. 
CalendarAnything is the most customizable calendar app for Salesforce. It allows you to display 
any standard or custom Salesforce object on a calendar. Download the free trial today and find 
out why CalendarAnything is the highest rated calendar application on the APPEXCHANGE.

https://silverlinecrm.com/calendaranything-help-center/
https://appexchange.salesforce.com/appxListingDetail?listingId=a0N3u00000MSzSIEA1

